Debian/Kali下GLIBC版本过低解决方法

 
Debian wheezy下的glibc版本为2.13,安装几个软件都运行不了,报以下类似错误:
xxxx: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by xxxx)

解决方法:把glibc升级到2.15版本:
添加软件源,刷新系统:

echo "deb http://ftp.debian.org/debian sid main" >> /etc/apt/sources.list

apt-get update

之后安装软件:

apt-get -t sid install libc6 libc6-dev libc6-dbg


complete!

来源:xiao106347

评论

© 泪王子 | Powered by LOFTER